Thursday, March 31, 2016

Configuring and Troubleshooting VLAN,VTP and Performing Inter-VLAN Communications.




VLAN Configuration on CISCO Packet Tracer:
-------------------------------------------------------------

1. Create the VLAN and Name them:
------------------------------------------------

S1(config)#vlan 10
S1(config-vlan)#name SALES
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name IT
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name ENGINEERING
S1(config-vlan)#exit
S1(config)#


Verify the VLAN Configuration
----------------------------------------

S1#show vlan


Configuring Trunk ports
------------------------------

S1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
S1(config)#interface fa0/1
S1(config-if)#switchport mode trunk

S2#config t
S2(config)#interface fa0/2
S2(config-if)#switchport mode trunk


Configuring VTP Information
-------------------------------------

1. Configuring the switches to be in VTP Server Mode and those in VTP Client Mode .
---------------------------------------------------------------------------------------------------------

S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#

S2(config)#vtp mode client
Setting device to VTP CLIENT mode.
S2(config)#

S3(config)#vtp mode client
Setting device to VTP CLIENT mode.
S3(config)#


2. Configuring VTP Domain
----------------------------------

S1(config)#vtp domain wazembe.net
Changing VTP domain name from NULL to wazembe.net

3. Verify VTP Configuration
----------------------------------
S2# show vtp status
VTP Version                     : 2
Configuration Revision          : 2
Maximum VLANs supported locally : 255
Number of existing VLANs        : 9
VTP Operating Mode              : Client
VTP Domain Name                 : wazembe.net
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x19 0x05 0x14 0x70 0x70 0x1A 0xFB 0x96
Configuration last modified by 0.0.0.0 at 3-1-93 00:39:55
S2#


3. Assigning of Ports to VLAN
------------------------------ --------

S1(config)#interface fa0/2
S1(config-if)#switchport access vlan 10
S1(config-if)#exit

S1(config)#interface fa0/3
S1(config-if)#switchport access vlan 20
S1(config-if)#exit

S3(config)#interface range fa0/2-3
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#


4. Assign IP addresses on PC and Begin Communicating within the same respective VLAN's
------------------------------------------------------------------------------------------------------------------


5. Inter-VLAN Configuration (Router on a Stick) to allow people on different VLANs to communicate
------------------------------------------------------------


1. Place a Router on any Switch. This Router will be used to perform communication between
VLAN
------------------------------------------------------------------------------------------
2. Create Sub Interfaces on the Router. The Sub-interfaces will be responding to the respective
VLANs
-----------------------------------------------------------------------------------------------
R1(config)#interface fa0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 10.0.0.1 255.0.0.0
R1(config-subif)#exit

R1(config)#interface fa0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 11.0.0.1 255.0.0.0
R1(config-subif)#exit

R1(config)#interface fa0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip add 12.0.0.1 255.0.0.0
R1(config-subif)#exit

3. Switch on the Sub Interfaces
--------------------------------------
R1(config)#interface fa0/0
R1(config-if)#no shutdown



4. Configure Trunk port between the Switch and the Router
-------------------------------------------------------------------------

S3#config t
Enter configuration commands, one per line.  End with CNTL/Z.
S3(config)#interface fa0/4
S3(config-if)#switchport mode trunk

No comments:

Post a Comment